Upgrade to WordPress 2.2.1, and an Apology

I forgot to mention that yesterday, we had the Peace Vigil as well as a showing of “Hotel Rwanda” at the Ames Public Library. Also, I upgraded to the latest WordPress, and the OpenID plug-in will be re-enabled shortly.

UPDATE: Good thing I keep backups. Pictures and other uploads have been restored.

This entry was posted in AGJ, Global War on Terra, Iraq War, System. Bookmark the permalink.